Eclipse cvc-complex-type.2.4.a: invalid content was found starting with element 'deployment' 錯誤


在開啟 JBoss 相關 XML 設定檔,

若出現 cvc-complex-type.2.4.a: invalid content was found starting with element 'deployment' 錯誤訊息,


則看看是否為 JBoss Tools 安裝版本無法識別的緣故, 如下 :

1) 因為我的 Eclipse Kepler 版本, 所以在安裝 JBoss Tools 時自然就選擇 JBoss Tools (Kepler), 結果就發生上述錯誤 :




2) 即使 Eclipse 是 Kepler 版本, 安裝 JBoss Tools 仍是選擇 JBoss Tools (Juno) 版本, 這樣問題就解決了 :

天聖經:神的心不僅在神的聖言當中,也在神所創造的萬物之中,天涯海角每一處都有神的心
Related Posts Plugin for WordPress, Blogger...